Bug with price percentages?

Has anyone seen this where the price is actually up but trading 212 reports it is down? Look at the screenshot for an example. The stock is clearly up from previous day (yahoo etc show as up), the line is even moving up but showing daily change well into the negative which is wrong.

This really spooks me how the pricing is all wrong. I want a reliable platform with data I can trust.

1 Like

I noticed this on countless ocasions. When it happens, I usually kill app, after reload it works fine… But yea, fix would be nice…

ok interesting, i’ll try that, thanks. just noticed the desktop version seems ok so just a mobile app problem I think. it appears all the daily % changes are out by a bit.

Hey @trader787! We found the problem and it is entirely on the front-end side. This only happens during the first few minutes after a market opens.

A fix will be deployed in the next version of the Android app. :robot:

In the meantime, @Vedran is correct that logout -> login or killing the app will fix the visual defect.

5 Likes

brilliant, thanks for the update, look forward to the fix :slight_smile:

2 Likes

Hey @trader787 as I said we did find the issue, but because the problem is outdated data on the front-end, we are still searching for a solution that will not blow our server up when the market opens :exploding_head:

Very sorry for the inconvenience this causes! I will ping you here when the fix has been deployed.

4 Likes

@trader787 I am happy to announce that the next update of the Android app 5.4.6, that will be on the Play Store shortly, features a fix for this pesky bug. :bug: :hammer:

4 Likes

Hmmm… Price down, graph shows down. But it is green and shows % postive. Pesky bug returns?

Strange, mine worked perfectly today, including Amazon that’s red right now. Wish it was green though lol

I have the Android app 5.4.6.

Exactly the same here

I tried a restart of my phone. That fixed it. All red now. :face_with_raised_eyebrow:

Unfortunately that’s how it should look :woozy_face:

Bear with us - a further fix is coming. We’ll keep you posted.

@Tony.V Thanks for the attention to this issue. I tried the trick of rebooting my phone and the graphs then appeared correctly. Maybe people need to reboot their phones after the new version is installed from the Play store. Of course, that should not be necessary and not every user will think to try it.

I was using yesterday the the android app 5.4.6 on a Pixel 2Xl when this issue surfaced.

@Richard.W Thank you for the follow-up - it is really helpful! :pray: