Pie Import bug Tesla post-split - ✅ Solved


I have all my holdings in a single pie made of several stocks, apart from 15 tesla shares that are outside the pie (bought manually).

When I go to my pie and press import and select all tesla shares (15) and press ‘confirm import’, error message came up saying ‘no connection with the server’.

I can import 5 shares in & out no problem at all, also tried other stocks works well. So the error is only present when importing in the very last share to make pie value = portfolio value.

I believe this is a bug need fixing, cheers.

Hey there @HM93, :wave:

We’ll need to investigate this further and get back to you when we have more information. Thanks for the detailed explanation! It’ll help us a lot to identify the bug.

We’ve found the bug which was causing this message to come up.

You’ll be able to import your Tesla shares now, @HM93. :slight_smile:

Hi @L.D

Thank you so much, Tesla imported successfully.

On the other note, I tried to play around with my apple share to export/import it. It’s very weird now that I have exported all my apple shares out of the pie, i.e 0 shares in pie. But the portfolio apple shows I have 2 shares in pie and the rest 6.6356337 bought manually.

My pie shows I have 0% holding / 9% target for my apple.

When I try to import my apple, I’m greeted with import of 6.6356337 shares. Upon pressing ‘confirm import’ the same error ‘no connection with the server’ occurs.

Thanks for your help so far!

Please see attached pictures to explain the problem better.

[edit: removed pics as problem have been solved.]

We’ll look into it right away, @HM93! :slight_smile:

Thanks for the screenshots and for the details you have provided us with. I’ll get back to you, once we have more information.

Hey there @HM93,

This has also been fixed now. You’ll be able to export and import shares to your pie.

Enjoy! :slight_smile:

Hi @L.D,

That is brilliant! I confirm everythings works now.

Cheers & thx for your help :slight_smile:

1 Like