T212 Contract Note Email Importer

TypeError: Cannot read property ‘appendRow’ of null (line 156, file “Code”)

did you forget to do this?
read the comments in the code there are things that you need to change

Solved! My apologies, I had understood “replace c1 with the sheet name” as the document (or spreadsheet) name, not the individual sheet. Thanks for your help, Happy New Year!

Now the export to csv is available in iOS app.
Just tried it to export dividend data and able to export.

Transaction and order history can also be exported to csv.

Can’t make this work after some hours on it
My portfolio is EURO so I modified this is what happens

  • The value is wrong when exporting instead of euros is thousands of euros (what do you put in the columns of portfolio performance, I think the value and gross amount are wrong in the col for me or something)

The iOS and Android apps have export functionality now. Will come to desktoop soon I think.

@kali Hi. Thank you for your elaborate post. I have been trying to use PP with CSV imported from T212 contracts as you had explained. It works well for most part. Only issue I find is when trying to get historical quotes from yahoo for stocks that have their prices mentioned in GBX and USD. PP considers the prices to be in GBP and messes up my entire portfolio. Any workaround for this ?

Set the currency as GBX image

@nickspacemonkey Thanks for your reply. I have imported the transactions from T212 contract CSV. So I am not able to change the currency now. I get a similar message as seen in your Screenshot saying that currency can’t be changed as transaction already recorded.

It would be nice to have a video on how you do it, even without sound it’s really interesting because I can make an import but the values are all wrong…