Trading212 won't load on Desktop on Firefox

Hi

26.02.21

Please can someone help.

The desktop website is not loading for me whilst using Firefox !

Https://live.trading212.com/beta.

It’s a white screen with …
'No Data Available" & a blue Retry button. Which does nothing!

I’ve fully cleared Browser history. Still nothing

Android phone app works fine but this on desktop… Just not showing me my portfolio data etc…

Would appreciate some help from team maybe look at my account etc.

Thank you

Did you try any other browser?

1 Like

Hi Rygel

Ok I tried it on Chrome and it worked fine.
So my next step will be to try updating firefox
again and see if that fixes it hopefully.

Unless any other ideas?

Thank you

Yes… Still the same problem!
I use Firefox for everything… but just updated to latest version and still nothing.

That is what I’m seeing!

Any ideas why?

Thank you

Try clearing the cache or deleting cookies.

1 Like

Tried that also… Clear Recent History… all cleared… All cookies, cache even the section that says Data: Site Preferences.

It logged out. I logged back in… But still the same!

But thanks tho buddy

I also use Firefox, but I have no problems.

1 Like

Hmmm… ok. I’ve no idea.

Refresh. Done.
Updated Firefox. Done.
Clear History, cookies Etc… Done.
Deactivated Adblocker. Done.

Can’t think what else…

It Highlights buttons the few busttons that I Can see… But nothing happens when I click…!

Firewall? Antivirus?

Change your security settings to accept cookies?

1 Like

The web address states
www.live.trading212.com/beta

Should this be “beta”?

Ok… Let me try this

Try switching to the old app (the arrow next to the INV or ISA circle in the top right corner)

1 Like

Also tried this too.
The click DOES drop down the menu…
But when I scroll down & click on
Switch To The Old App… Nothing happens.

So now… I’ve tried this as well as :
Refresh. Done.
Updated Firefox. Done.
Clear History, cookies Etc… Done.
Deactivated Adblocker. Done.
Firefox Cookies : Standard.

If I’ve set something wrong… Surely the Firefox update would have set things right. I think

Appreciate your help :+1:t2:

I see that never @stonelane1827 was also having similar problem on Firefox as me on Nov 20.

Same as me… Updated Firefox tonight, cleared all caches chickpea etc.
Adblocker Off.
Log off log on.
Works on Chrome… But stuck on white limited screen on Firefox…

Wondering if there was a solution then? Anyone?.

Tried the DESKTOP site through my android phone … Using Firefox (NOT through my App that I downloaded on play store)

So through this…using the desktop site, In Firefox…through Android

https://www.trading212.com/en/login

It actually worked !! But it won’t come up when I try typing in same URL into my desktop pc Firefox .

Any programmers technicians staff anyone at all… Any idea what it could be…I would be very grateful I assure you!!

Tried a refresh, which effectively creates a new FF user profile?

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Also, try running in private mode as below (at work, we can only access parts of Exchange Admin in Chrome’s incognito mode, for some reason, so may be worth a shot).

https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history

1 Like

Ok thank you I will try this…

Thank you very very much Philby.

Firefox Refresh (new FF profile) - Nothing.
Firefox Safemode - Nothing.

But… in the Incognito mode/Private Window it worked fine! So…bit of a pain but at least works in that mode. Funny how we get stuck to our little ways…as i say, its a bit of a pain but its like I’m saying its a massive issue when i suppose its opening a seperate window!!!

But i feel a bit better that at least I can now access it on desktop, AND on FF.

So massive thank you. Really appreciate it. (and to all who tried to help)

Thankyou.

1 Like