Web App not loading

Since yesterday, the web app cannot load in any browser (Chrome, Firefox, or MS Edge). I am using Ubuntu 22.04.3 LTS. It loads the splash screen and then shows a blank page. I cleared the trading212 site data from all browsers, and still getting the same issue,


The app is up and running. Let me DM you to check what’s causing the difficulties.

1 Like

I find myself in exactly the same situation. Been over a day and a half with no progress or detailed feedback from Chat. Screen goes blank aferr the orange invest page after logging in.

I’m sorry to hear you have similar difficulties with the app.

We just rolled out a possible fix to tackle the described situation by @Quixote. Could you please try again and let me know if everything is back to normal?

Unfortunately not. Still the same result

Let me send you a DM so we can check this further :pray:

I’ve tried again now, and still getting the same blank page.


All working normal here.

@MaxZorin , they’ve fixed it today early morning. It is normal now.

Indeed, we applied a fix :ok_hand: Still, if someone has difficulties, drop me a DM, and I’ll take care.

I am also having this issue, my web app hasn’t loaded for a few days and is just stuck on a trading212 loading screen

I’ve sent you a DM - please check your inbox :envelope_with_arrow: