Bug? Unwanted auto-correct with share value


Is there any way to fix this problem? It has happened quite few times before and applies to both GIA and ISA. In this instance it is ADIG. You put in the number of shares you want:

But as soon as you review purchase, it wants to take your whole balance:

There is no way to stop it, as soon as you revert it to 2, it goes back to its 2.1.

It’s especially annoying in this instance because I have been able to do the workaround previously to reduce the purchase to fewer shares and then do an additional purchase for the rest, but that cannot be done in this case as reducing the purchase to 1 share brings it below £1.

Hi there. This is an intended behaviour, not a bug.

Until recently, it was not possible to place a “number of shares” market order worth more than 95% of your free funds. This rule was in place to protect you from investing more funds than you have available in case of a sudden market movement.

We decided to change that logic in order to allow our clients to place an order with 100% of their free funds, while still having a negative balance protection in place. So as you observed, when you now try to invest all your available funds, the quantity order is automatically changed to a value order. If your default option is ‘Number of shares’, dragging the slider to the maximum amount will automatically convert the order from quantity to value.

OK, very disappointed to hear this if I’m honest as I don’t want to end up with fractional shares, accidentally or otherwise. This means I’ll perpetually have to keep a balance behind if I want to avoid that.

Is there any way to switch off fractional shares for my individual account? That way I could still buy when the display sets to 2.1 while at the same time making sure the actual purchase would only be 2 shares.

If it isn’t possible to switch off fractional shares, could this feature be developed?

Even if it was possible, switching off fractional shares would not solve the problem of your order value surpassing your available funds due to market fluctuations while being completed. In a sense, nothing has changed to make it harder to have only whole shares in your account.

Before the change I explained above, you would have received a pop-up message saying, “You cannot invest more than 95% of the available funds in your account”. We simply made it easier for clients to use value orders in cases like these. Unfortunately when you use ‘number of shares’ order mode, this small “buffer” must stay in place in order to prevent a negative balance.

While I understand the inconvenience, keeping a small amount behind will also enable you to earn interest on uninvested cash.