Latest Android app not working

Downloaded latest Android app 5.20.4

Running Android 11 all latest updates

Hi @pbigmoon

I will send you a DM.

1 Like

I am also finding new update does not work. 5.20.4

@Richard.W Reinstalling the app should fix it. DM me if the matter persists.

1 Like

Leave beta program uninstall then reinstall

Looks like someone @Team212 needs to look at the latest beta version as it doesn’t work

Here’s my phone info incase it helps pixel 3a XL

App no longer working for me either!

We are looking into it, will keep you posted.

Edit: A fix has been uploaded. It will take some technical time till the update is distributed.

1 Like

App still not working for me on my Samsung S7 Android 8.0.0

Edit: A deletion and re-download of the app worked.

Have you updated to the latest version? It works for me after the release yesterday late afternoon.

Got it. I deleted and re-installed the app and it works fine now. Thanks for the advice and thanks also to @Y.M for his message.

1 Like

Yeah version 5.21.0 works