Limit Orders processing for a long time (LSE:PHE)

I have created limit orders for PHE but they are still processing.
Market orders seem to work fine and are processed as expected.

As you can see in the screenshot the first limit order was created at 10:33 and is still processing. The market order created 26 minutes later is already processed.

Had the same earlier this week. Refreshing browser tab solved it. Appeared it was already processed.

I tried refreshing and relogging. They were still processing. I also cross-checked with the app - same result.

Now, 1 hour after creating the orders, they seem to be processed.

I put 15 sell limit orders in last night around 10pm and then decided to cancel which j find so about 30 mins later after changing my strategy. It was pending cancellation up until 6am this morning. I was panicking all night that it wouldn’t cancel in time for FTSE open.
I too refreshed, logged out and hoped it would sort itself out which it eventually did.
Thank god the open was 10 hours after I closed the order.

@Doydoy Orders aren’t accepted instantly by LSE, the reason being its specific trading conditions -> LSE AIM, SETSqx.


3 Likes