Stop-limit order not executed - ✅ Resolved

This is a screenshot from a 3x Microsoft instrument today. What is the problem with the Stop-Limit? why is it not triggered?

You are going SHORT so shouldn’t that LIMIT be above the STOP?

34.38 is less than 34.40 so it wouldn’t trigger yet?

Nope. I’m saying if the price falls below 34.40, sell it at any price better than 34.10. The only reason I could imagine this is not working is because there might not be enough transactions going on, but then I reduce the quantity to 1. It still doesn’t work.
I just tried a similar one with Alibaba on my practice account and it worked ok. Not sure what is going on.

1 Like

Sorry that was me being dim, so yeah you are in Invest/ISA and have set a SELL STOP LIMIT order.

The stop should have triggered to create the LIMIT order at 34.10.

As you say maybe its liquidity.

I just tried to sell 1 share using a market order and it got executed instantly.
I had a feeling that the Stop-Limit has not worked a few times in the past, but now I’m more skeptical. Has anyone else had any similar problems?

It’s not a case of how its executed is it? Like the limit is at auction times to help improve liquidity?

Well, the order was there for quite a time and it moved a few times around it. Nothing happened!

Ok another example. This time with 2x Facebook

And here is a video:

Just happened to me, albeit in demo mode. See pics.

A minute or so later…

Any update on this? I had a limit order today after market open for SPCE at $19.65. I watched the price hit this a few times and the limit order was not executed. Granted I could have done a market at that time, but I want to use limit orders to get the entry price I want.

@ASH_APP Could you please provide me with your email address via PM, so we can check?

@liamt I’ll look into it

I’ve just sent you a PM with additional details regarding your case.