Tried Beta version, can't go back

I tried the Beta version of the site, but nothing is loading. Now i try to go back to regular version, it’s not allowing me.

I also have pending order that i try to cancel, but it’s stuck on loading, it’s been 12 min…

Don’t try to delete the “/beta” part of the URL, instead, use the menu on the top right and click “Switch to the old app”

That’s what i’m doing, but clicking it just reduce the window, and does nothing. I actually tried to click on any of the buttons on this page, nothing is working, i can’t even log off. I also tried to close browser, clear cache and everything. i’m stuck on BETA.

Try logging with a different browser or with the same in incognito/private mode so you will be required to put your login credentials, does it redirect you back to /beta?

Thank you, it did work, but i got to say, i had to download a browser (google chrome) just to do that. It’s sad…

But Thank you, a lot!

It should work on your old browser as well now. T212 remembers your preference

Perhaps you might know the answer to my other issue. I’ve got a pending modification of limit buy. it’s been stuck for 50min on “processing”. I’m scared that it’ll go off after my stock goes down. Any way to force canceling it ?

I have no idea i’m sorry, try creating a new topic and maybe tag a T212 member