Unable to deposit funds

Hi, I’m new to Trading 212 and am excited to start trading.

Unfortunately, I’m unable to fund my account using any of the available methods as it keeps saying that the card was rejected. I’m pretty sure the card works fine as I funded my TransferWise account as well. I even tried to do a wire transfer through TransferWise and it bounced back almost immediately. I wonder if it has anything to do with my country (Sri Lanka) or something wrong with my account. Hope you guys can help me get this sorted.

@Rebmeister Everything is working fine on our end, and there is no limitation which might prevent you from depositing.

Our recommendation:

  1. Make sure that you’re using the latest version of the app
  2. Be sure to contact your bank, so that can confirm further whether they’re blocking the transaction - I suppose that this is the case here.

That still doesn’t explain why the bank transfer through TransferWise bounced back. Are there any restrictions fro sending money through TransferWise?

It’s all good on our side, and we don’t place such restrictions. However, judging by the screenshot above, it seems that there was something wrong with the bank details that you have put in your TransferWise account. Better would be to follow the steps that they have provided you with