Incorrect warning of insufficient funds

When I try to set a limit order (GTC), it doesn’t work, it says I cannot place a single order worth more than 95% of my free funds. However, I can assure you I have no pending order as well as the amount of shares and price I set would be less than 95%, in fact it would be like 80% of my free funds. What’s wrong here? Thanks!

Well, I believe the 95% takes in account the current price of the stock, not the price I set as limit. It doesn’t seem to be logical. :thinking:

Maybe you have multiple orders , meaning some other shares have set limit order. So you lack funds for this specific order? As the amount of orders which can be set are not surpassing your total free funds.

So let’s say you have 60$ free funds, limit order 20$ for Stock A, 30$ Limit order for stock B , you want to place 40$ limit order for stock C, it fails with lack of funds error.

1 Like

Thanks! But I don’t have any pending order for any other shares. That would be the only one I would set.

I have 106 USD, then 95% would be 100,7. I tried to set 5 shares for 16 usd, which would be 80 USD, but then I got that message. When I tried to set this the current price was around 20,70, so 5x that would be more than 95% of my free funds. i don’t have any other explanation…

1 Like

See Limit buy order won't get approved

1 Like

Thank you, that solved my doubt. I did a quick search but didn’t come up with that thread.

@David It would be great to see a different setup for this. Not sure how