Pie custom distribution did not make any investments

This happened to me this morning but I wasn’t in a position to write it up at the time, hopefully this might give you something to go on looking through any logs.

I went to invest in my ISA pie and did a custom distribution of a 50/50 split between two of the elements in the pie. Everything appeared like it worked, i.e there was no indication anything had failed and no error dialogs, but the whole amount just ended up as spare change in the pie, and checking my history no market orders were attempted.

I thought I had just pressed cancel or done something silly so I withdrew the free cash from the pie and tried again and the second time it did the same thing and ended up as free cash in the pie again.

I then tried a third time (this time I accidentally put a couple of quid extra in the deposit) and followed the same process, which worked successfully and I ended up with 2 market orders as expected.

Probably not relevant, but for the sake of completeness the cash I added to the pie was all from free funds in my account and not a deposit. The first attempt (before I withdrew the free cash and started over) I’m pretty sure there were a few pennies in the pie as spare change as well.

Don’t know if it was something like the amount I tried to invest wouldn’t split equally between the 2 pie elements at current prices, but if that were the case I would expect 2 orders to have been placed and a few pennies left over as spare change. In any case there were no error messages, and had I not been paying attention I would have thought the amount had successfully been invested.

1 Like

Honestly, my first thought on glancing over this was to ask if the market was open at the time xD

They were both ETFs on LSE, and it was shortly after 8am so the market was definitely open.

Either way, if it was on a closed exchange I think it sits spinning on “Investing” until the relevant exchange opens rather than dumping straight into free cash? Pretty sure that’s what my last auto invest did, and I don’t immediately see a reason a manual investment should behave differently.

all of my manual deposits have gone straight to free cash balance in the pie and the investing bar also activates along the top until market opens or the shares purchased. when the markets are open this usually doesn’t take long at all, but when shut it prevents me from making any further changes.

I do stocks however and liquidity is almost always guaranteed for those shorts of things. ETFs, depending on type and thus its liquidity may behave differently in the pie’s. its all done OTC via T212 as they are fractionals so it’s possible you were waiting for T212 clients to sell shares or for T212 itself to settle. will be interesting to see the pie’s once all known bugs are sorted and its safe to roll out wide-scale and with the additional requested features.

@George you seem to be king of the pies at the moment, not sure if you’ve spotted this thread or not?

@Dao I take your point about the liquidity, but I guess my assumption would still be it spins in pending if there were no readily available units of the ETF to trade. The fact I didn’t see anything in the history (like a cancelled or modified pending order) and the money immediately went to free cash makes me think either the system bailed on me, or I just did something daft, which I’m more than happy to accept if that’s the case.

daft things, either you or the pie, seem to happen with an oddly frequent rate this year :S wouldn’t surprise me.

Sure @BenP, we’ll take a look at what happened here. Thank’s for carefully describing the flow of events!

1 Like

We found a small bug related with the custom distribution sliders. It caused your pie to order shares for more funds than actually available and thus the operation failed and cash remained uninvested.


Great stuff, happy to help.

Now you mention it I think I did start with the sliders but I find most sliders on a phone a bit jumpy the wider the range and I never get the right number straight away, so I think third time trying I may have just typed 50/50 in each box which is why that one worked.