Stop Loss Distance Too Far - EGO - CFD

I’m trying to set a stop loss up on EGO for CFD trading but it keeps saying ‘The Stop Loss distance value is too far from the current market price’. I’m only setting the distance about 20% less for the market value? Please can anyone help as I don’t want to keep having to set price alerts

Happens with take profit too. Very annoying.

Is there a way to get around it?

@David @PeterA are you guys able to adjust the settings on this instrument?

Hello, @J7G! We’ve just amended the settings, apologies for the delay.

No worries Martin, thanks!

How about TP (CFD) Martin?


Could you please provide me with the name of the security in question?

OCDO @Martin Thanks.

You can check it now. :v:

1 Like