Unable to cancel limit order

I placed a couple of limit orders yesterday, but i wanted to cancel but a little wheel keeps spinning saying processing with no option to cancel.

Are you clicking the ‘X’ on the right hand side of the relevant order?

No the X is replaced with the spinning wheel, ive tried logging in and out also tried on my pc still the same, its been like that since Saturday.

Ah I see, I just set up a LO in my demo account to test, I cancelled it without any problem.

If you’e usng real money I’d email CS sharpish. Sorry I can’t help any more but at least you know it works for someone else

Thanks for the reply, yes i tried it there as well, yes i have sent them a couple of emails, otherwise could be a very expensive mistake.

Just out of interest, did it work for you in the demo account or was it not letting you cancel there either?

Yes it worked fine in demo, and last week i placed a couple of orders after hours, with no problem. I did see someone else asked about the same problem a few weeks ago, but there wasnt a solution identified it just resolved its self.

1 Like

I’m having the same issue. I just get a spinning wheel. I’ve only realised I was supposed to place a stop order not a limit order.

All but 1 of mine have now changed and ive been able to cancel them. I still have 1 spinning, see what happens when market opens.

this often happens if you place the order during market close. sometimes you end up needing to wait for the market to open so you can amend your order.