Unable to modify open positions

Pending orders and price alerts are not affected. Tried right clicking and then using ‘Edit Order’ also tried clicking on the position, nothing happens either time, have refreshed page many times to no avail, please could someone look into it ASAP before it causes problems, thanks.

2 Likes

I experienced the same about an hour ago. Fine on mobile but not on PC or laptop using Edge or Chrome. Tried clearing cookies, etc., but no joy. Also cannot view position history so suspect server issues. :frowning:

4 Likes

Same here about 1:00 - 1:30 hours ago on my PC but on the mobile it worked fine

1 Like

same here looking like a bug for more than just a few.

1 Like

Oh good, I didn’t try the mobile, at least that’s there as a backup then, that’s better than nothing. About 30 mins after I made this post it started working again but now it’s down again so looks like it’s intermittent

Same for me on Web UI, works in Android mobile app.

We’re working on it. The issue’s only with the web client, the mobile app’s working fine.

2 Likes

Resolved - just do a refresh & all should be fine.

3 Likes