VRM has still not been added

Hi, we’ve missed the VRM IPO could we please get this added ASAP so we can at least buy the bloody stock!




Agreed. This needs to be added ASAP. Definitely want to dip into it


“After Doubling On Day 1, Vroom IPO Could Rev Higher” - Seeking Alpha - and we’re going to miss this opportunity thanks to T212 @Joey_Fantana


I feel the issue here is that because of what is going on, as a rule, 212 are not looking at this section of the forum.

Perhaps needs to be posted in Help section to get some attention?

And AZEK goes live tomorrow. And FEAC still not added.

1 Like

@mcwilliams91 is there somewhere else the above discussion should be taking place / posted to get the attention of @Team212 - there’s been not a single response for days and it’s getting quite silly to have such delays on stocks being added.

Afraid not @AdrianUK.

I fear the CFD issue from the other day has taken up more manpower to correct, and it’s taken up everyone’s time. While I sense your frustration, alongside others, I unfortunately don’t work for T212 so tagging one of the team is the way I’d do it also. I’ll try my best to prise out an answer.


Of course, I can appreciate that! I’m still a newbie and you seem to have a good sense of the @Team212 hence why I roped you in lol cheers for the reply!


Sorry for the delay guys, it’s live now. If you’re certain an IPO’s happening, ping me, @Martin or @PeterA, preferably more than once until one of us responds.


if you mean VRM, i still can’t find it

@H2T2 Refresh & you should see it.

1 Like

@David can you please add fractional shares of it too?

@aldrinholmes Done. :+1:

1 Like

Any chance we could get the Renaissance IPO ETF added, plz! :slightly_smiling_face:

1 Like

I’m Not able to buy AZEK, keeps saying my transaction has been rejected.

Has it gone live yet?

That one is not available in Europe since it is not UCITS, won’t be added.

Actually I can see it has but the price seems wrong - $29.50 where the actual price is currently $23.

@David @Martin @PeterA can you advise please?

I’ve bought some. Went through okay. Just seems to have applied the wrong price.

@AdrianUK @David @Martin @PeterA


1 Like

Well I’m not even able to buy yet, my purchase keeps getting rejected lol

App or…?

I’m on the app.

1 Like