Instant Bank Transfer - 'Unable to connect' - ✅ Solved

When trying to connect my NatWest account to T212 for instant transfer it tells me it’s unable to connect because my bank account name and T212 account name doesn’t match after being redirected back to T212. It connects with TrueLayer okay but the last stage with T212 is where the problem lies.

Is it just a formatting issue that T212 needs to amend because it doesn’t recognise my NatWest account name eg. Smith AB when matching up to my T212 name eg Alan Smith?

You need to get your middle name added to 212 account. That’s what I did and it solved the issue.

I got them to add my middle name but it still doesn’t work :frowning:

@George or @L.D should be able to help

(Edit: got the @ correct eventually…)

We’ll take a closer look, @xavier . Thanks for letting us know. :slight_smile:

I’ll keep you posted.

Hey there @xavier,

You should be able to connect your account now. Try again by using the same one. :ok_hand:

Awesome, it’s working now thanks @L.D :slightly_smiling_face:

1 Like

Im having the same issue, I had my middle name added but the transfer method still says the names don’t match

I have the same problem, how can I edit my info?

I’m having same issue. I’m guessing not included middle name when signing up or not put the details exactly the same as they are on bank account. Can anyone help with this. Many thanks