Very slow app startup on Android?

Is it just for me that the Trading212 app on Android is the slowest among all other apps on my phone to start up…it takes like at minimum double or triple the time to start, compared to all other apps, including YouTube…

Notes:

  • I tried it on 2 phones and on both it’s the slowest app on the respective phone in terms of startup…
  • This has been happening since forever, I just didn’t make a post so far…

I get that sometimes. Assume it’s a bug on the latest update. It gets stuck on the logo page, and I tend to force close and restart.

Nonono…it doesn’t get stuck…it simply takes a lot to load (relative to any other app).
And it was this slow since forever.

Hey, @trade. :wave:

Clearing the cache or reinstalling the app should do the trick. Nonetheless, I’ll DM you so we can check this together.

The 2nd Phone is new. YouTube still loads significantly, visibly, faster than T212, any app does.

Maybe the devs programmed something to happen at the startup, before the splash screen goes away.

That’s the problem, there’s a slight delay before even showing anything, then it shows the splash screen for a ridiculous amount of time (again…relatively speaking), then it starts showing that it loads for a bit, then I’m in.

A solution would be to check my theory, and if that’s the case, and if possible, they should do any computations only after giving some feedback to the user, showing a loading bar or such. Rather than too early…

Since the last update i’ve been struggling with the app also, the app is freezing and failing to launch, sometimes the prices don’t load, and exactly as you said when the app does launch correctly its buffering for 5-6 seconds before it finally opens, highly irritating and a massive step backwards…and why on earth have the account buttons been re sized bigger? Now they are slow to move to switch between accounts, I’m really not impressed…It was very fast and responsive prior to the ‘update’ with no fix in sight…I asked about these faults weeks ago, nothing has changed.

I’m on Android also, anyone having any of these issues on Apple?

Same issue on Android.

@Bogi.H It would be also great if stocks price data would be held in cache instead of user data storage. I have user data now more than 3GB, cache around 200MB. If I clear user data I will lost all my settings including individual graph settings for each stocks. This is really annoying if you want to clear up space. The rest is synchronized from server, no issue there.

Hello, :wave:

There is a problem with Android that the “connecting” indicator is not displayed in time, which may give the impression that the application is still showing the “splash screen” when in fact, it’s performing a login request.

We are still working on a fix regarding the latest update of Android 12. The main reason for this appearance comes from Google play itself - sometimes, they distribute new updates through heavy caching, which restricts access to newer versions.

In the meantime, please try to clear the Google Play Store cache. On the other hand, we will keep the updates coming on the matter.

2 Likes

Second this. i’m seeing this across Android and iOS both. Seems like the script to fetch data plot it has become extremely heavy and cumbersome

2 Likes

Same here. The app feels very slow to start on a phone with Android 11, an SD855+ CPU and 8 GB of RAM. That and the unbelievably high usage of 3+ GB for data. Why is this needed? It is by far the most memory-greedy app on my phone. Cache is just a megs which is ok.

1 Like

Hi guys, Just to confirm, clearing the cache on google play does absolutely nothing to help with the app issues. Any more suggestions?

A reminder that my post has nothing to do with any update of the app.

It’s been like this since I first used it back in 2020.
I just didn’t bother making a post about it.

It was slower before but now it sometimes stuck whole phone for 30sec or even more. So something changed in recent updates (cca 1 month ago)

true. didn’t have this issue earlier though. i seem to remember this is very recent for me, both on android and ios. i believe sometime earlier this month of the previous.

Thanks, everyone, for the constructive feedback. We are working on optimizing the application and reducing the log-in time. We’ll let you know as soon as there are any updates.

In the meantime, let us know if you encounter similar unexpected behaviour.

6 Likes

I am experiencing the same issue on the latest iOS. Need to wait 5 seconds until the connecting text appears. Before it was instant.

Hi guys,
I have this issue with the app. I had an older phone and everytime i tried to launch the app, it would show the T212 logo and just hang. I would have to open my app drawer, close the app and relaunch it. i thought it was because my phone was getting old so i changed it. yes, T212 prompted a 800 euro phone upgrade!
Now i have the new phone and the same thing happens. 8 out of 10 times, i launch, it shows the T212 logo and nothing. Have to close and relaunch, i see the blue screen and it works fine.
I have deleted the cache, i have reinstalled, i have force stopped and relaunched, i have checked if the battery saver settings are there (not turned on for this app)… nothing seems to work.

would appreciate if someone could help me !

Readers, can you confirm it happens to you too so I know I’m not the only one.
Android phone running latest android version. Previous was also android.

2 Likes

This is happening to me also, When I open, I just got a white screen with the logo in the middle. I have to force close the app before it will work. This has been happening in the last 2 updates of the app.

@dabear, @kachaka, @Buurbachi I’ve reached out to you via DM, please check your inboxes :mailbox: - we’d like to have a closer look at the difficulties you’re experiencing.

1 Like