Very slow orders - More than 15 mins?

Today, Strangely, why are my market orders not executing? Tried to buy RIG at market open and still not executed. Have multiple market orders cancelled, retried, does nothing. Is something broken?


Something is going on for sure. I face similar issues.

1 Like

i just put a sell order through pending for 5 mins then stops i cancelled it and still automatically went through 5 mins alter.

1 Like

Eurgh, my first negative platform experience here. It killed a few deals for me.


Had same issue yesterday. Went from +100 to -100 at open because my market order didn’t go through

Same today with Gilead, put market order to sell last night, hasn’t gone through since 25 mins, costing me -100 to breaking even and almost now losing as we speak.

It’s really poor from T212. The last few days have cost customers. I’m sure I’m not the only one.

I had an order sit pending for 5 minutes so I cancelled it. A few minutes later it says “order executed.” I then sold the order and after minutes it still has not sold. I also set a stop order that did not go through so i cannot even get up and walk away from comp.

Happened same with mine but luckily no damage done. Hope this doesn’t happen again.
I guess order was in queue but executed after cancelling.

We’re aware of this, It may happen in the first few minutes after the U.S. session starts. It’ll be resolved very soon.


Thanks David. I trade regularly on the US markets and today is the worst it has been for me (rarely more than 30-60 seconds but perhaps I have been lucky in the past?)

My order been sitting there now for 30 mins. This issue only started yesterday was hoping it was resolved but it’s come back today…

1 Like

I am having this same issue… not the greatest as I chose to sell at that limit so why is it not honoured? If the market was going the other way and I couldn’t back out of a trade in time it would be very detrimental. T212 can you provide an explanation please?

I’ve been sitting on a market-sell for 11 minutes now

Seems to be working now for me

David, how do I know if my limit order has been placed? I set the system to but if the stock reach a certain price but I cannot see it in my order hystory

Thanks David for the reply.
I think the best way to solve delay execution issue is to give the customer possibility to cancel the order, even when is loading/processing, which is not possible now. Delays can happen time to time due to various reasons like internet connection, exchange overloaded, etc. In these situations the platform should still give you the ability to cancel your order.
Thank you.


Still can’t execute a market order on Transocean (RIG)

Yeah this is a problem I have had before, bit scary.

Ok seems to have finally gone through

SEems to be working for me now, but I did just have a case where I owned shares in a stock and when I tried to set a limit order I got “you have to own this stock sell it” yet I was able to sell at market.

It’s back to normal now